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License for Use of ECH2O Utility Mobile Software

IMPORTANT NOTICE! Read Carefully Before 
Installation and Use! 

ECH2O Utility Mobile Software is owned by Decagon Devices, In-
corporated. ECH2O Utility Mobile is not free Software. You are re-
quired to purchase a copy for each device where ECH2O Utility
Mobile is installed. By using this software you agree to the following
terms and conditions. If you do not agree to the terms of this License,
do not use this Software.
 

1. Grant of License. Decagon grants you, the user, a nonexclusive license to use
this Software solely for use with Decagon instruments. This software is not
sold to you.  The user may not reproduce, distribute, sublicense, resell, or oth-
erwise transfer for any consideration, or reproduce for any purposes, the Soft-
ware or any modification or derivation thereof, either alone or in conjunction
with any other product or program. Further, the user may not modify this Soft-
ware. This license replaces and supersedes all previous licenses provided by
Decagon.

2. Disclaimer of Warranties. THIS SOFTWARE IS PROVIDED TO THE
USER "AS IS."  DECAGON MAKES NO WARRANTIES, EITHER EX-
PRESS OR IMPLIED, WITH RESPECT TO THIS SOFTWARE AND/OR
ASSOCIATED PRODUCTS AND/OR MATERIALS PROVIDED TO
THE USER, INCLUDING BUT NOT LIMITED TO ANY WARRANTY
OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE
OR AGAINST INFRINGEMENT. DECAGON DOES NOT WARRANT
THAT THE FUNCTIONS CONTAINED IN THE SOFTWARE WILL
MEET YOUR REQUIREMENTS, OR THAT THE OPERATION OF
THE SOFTWARE WILL BE UNINTERRUPTED OR ERROR-FREE, OR
THAT DEFECTS IN THE SOFTWARE WILL BE CORRECTED. FUR-
THERMORE, DECAGON DOES NOT WARRANT OR MAKE ANY
REPRESENTATIONS REGARDING THE USE OR THE RESULTS OF
THE USE OF THE SOFTWARE OR ANY DOCUMENTATION        PRO-
VIDED HEREWITH IN TERMS OF THEIR CORRECTNESS, ACCURA-
CY, RELIABILITY, OR OTHERWISE. NO ORAL OR WRITTEN
INFORMATION OR ADVICE GIVEN BY DECAGON OR A
DECAGON AUTHORIZED REPRESENTATIVE SHALL CREATE A
WARRANTY OR IN ANY WAY INCREASE THE SCOPE OF THIS WAR-
RANTY.

3. Limitation of Liability. BY USING THIS SOFTWARE YOU AGREE
THAT DECAGON IS NOT LIABLE FOR ANY CLAIMS OR DAMAGES
WHATSOEVER, INCLUDING PROPERTY DAMAGE, PERSONAL IN-
JURY, INTELLECTUAL PROPERTY INFRINGEMENT, LOSS OF



PROFITS, OR INTERRUPTION OF BUSINESS, OR FOR ANY
SPECIAL, CONSEQUENTIAL OR INCIDENTAL DAMAGES, HOW-
EVER CAUSED, WHETHER ARISING OUT OF BREACH OF WAR-
RANTY, CONTRACT, TORT (INCLUDING NEGLIGENCE), STRICT
LIABILITY, OR OTHERWISE.

4. Construction. If any provision of this License is inconsistent with, or cannot
be fully enforced under, the law, such provision shall be construed as limited to
the minimum extent necessary to be consistent with and fully enforceable un-
der the law. If for any reason a court of competent jurisdiction finds any pro-
vision, or portion thereof, to be unenforceable, the remainder of this License
shall continue in full force and effect. 

5. Applicable Law. This License shall be deemed to have been made in, and
shall be construed pursuant to, the laws of the State of Washington. The United
Nations Convention on Contracts for the International Sale of Goods is spe-
cifically disclaimed.

6. Title. All title and copyrights in and to the Software the accompanying print-
ed materials, and any copies of the Software, are owned by Decagon Devices
Incorporated. This Software is protected by copyright laws and international
treaty provisions.

7. Termination. This License will automatically terminate if Customer fails to
comply with any of the terms and conditions hereof. In such event, Customer
must destroy all copies of the Software and all of its component parts.

8. Complete Agreement; Governing Language. This License constitutes the
entire agreement between the parties with respect to the use of the Decagon
Software licensed hereunder and supersedes all prior or contemporaneous un-
derstandings regarding such subject matter. No amendment to or modification
of this License will be binding unless in writing and signed by Decagon. Any
translation of this License is done for local requirements and in the event of a
dispute between the English and any non-English versions, the English version
of this License shall govern. 

9. Enforcement. The provisions of this Agreement shall be enforceable regard-
less of any other claim or dispute existing between the parties, and in any action
for violation of the terms of this license, the prevailing party shall be entitled
to recover costs and attorney’s fees. Jurisdiction and Venue shall be in Whitman
County, Washington.   

ECH2O, ECH2O DataTrac, Em50, Em50R, Em5, and Em5R are registered
trademarks of Decagon Devices, Inc. ECH2O Utility, ECH2O Utility Mobile,
Em5b, EchoLink and DataStation are trademarks of Decagon Devices, Inc.

Copyright ©2004-2007 Decagon Devices, Inc. All
rights reserved.
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1. Introduction

Thank you for purchasing ECH2O Utility Mobile.
ECH2O Utility Mobile allows you to collect data from,
and change settings in the Em50, Em50R, Em5, Em5R,
and Em5b loggers using a Pocket PC PDA. ECH2O Util-
ity Mobile will also work with the DataStation, which acts
as a data collection point for multiple loggers. 

This program has been designed for ease of use and incor-
porates many features to make your job easier. This man-
ual is designed to help you understand and fully utilize
ECH2O Utility Mobile to accomplish your sensor mea-
surement goals efficiently. 

NOTE: A Pocket PC device is different from a desktop or laptop
PC in that it uses some different conventions that you may not be
familiar with. Program settings are made anytime the “ok” button is
tapped. On a PC a cancel button is often available to you so that a
particular action can be discarded and changes not made. Since a
Pocket PC device does not give you a cancel button, you will have to
initiate the action, change the value back to what is wanted and then
tap the “ok” button. If you make a change in a control on a form
and decide the change is not really needed, you can change the setting
back and then tap “ok”. Whatever settings are chosen when the
“ok” button is tapped are the settings the program will use.

System Requirements
To use ECH2O Utility Mobile, you must have a PDA,
Pocket PC, or Windows Mobile device with the following:
1
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•  Pocket PC 2003, Pocket PC 2003SE, or Windows
Mobile 5 and operating system

•  Display with a portrait orientation
•  Available serial port

To install ECH2O Utility Mobile on your mobile device,
you must have Microsoft ActiveSync 3.7 or newer installed
on a PC running Windows 98, Windows 2000, or
Windows XP. You also need ActiveSync to transfer data
files collected within ECH2O Utility Mobile to your desk-
top computer. See your mobile device’s user manual for
more information on using ActiveSync.

To connect to the communication port of your ECH2O
loggers, you need a Decagon Serial Cable Adapter. This
cable has a standard 9-pin female connector and a 3.5mm
stereo connector.

HP iPAQ Pocket PCs
Decagon stocks adapter cables for HP iPAQ mobile
devices. Not all iPAQ models have an available serial port.
Please determine if your model iPAQ supports a serial
port before trying to install ECH2O Utility Mobile. 

Compact Flash Serial Cards
ECH2O Utility Mobile supports Compact Flash (CF)
Serial Cards. This is useful for mobile devices that don't
have a built in serial port. We recommend using Socket®
Serial I/O CF Card or Socket Ruggedized Serial I/O CF
Card. You must use the Socket serial driver and Socket
utility to identify the COMM number of the serial port.
See http://www.socketcom.com for more information.
2
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Recommended System
Decagon recommends using the Archer Field PC from
Juniper Systems with ECH2O Utility Mobile. This ultra-
rugged mobile device has a robust serial port and is
designed to work in field conditions where typical PDA
hardware will fail. Contact Decagon for information on
purchasing the Archer Field PC bundled with ECH2O
Utility Mobile.
3
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Contact Information
To contact Decagon:

• E-mail us at ECH2OHelp@decagon.com
• Fax us at (509) 332-5158
• Call us at 1-800-755-2751 (US and Canada only) 

or 509-332-2756.

Warranty Information
ECH2O Utility Mobile has a 30-day satisfaction guarantee. 

Suggestions
Please report any bugs, and send suggestions for
additional features to ECH2OHelp@decagon.com.
4
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2. Installing ECH2O Utility
Mobile                    

Installing ECH2O Utility Mobile
from CD
ECH2O Utility Mobile installs from the CD found in the
front cover of the ECH2O Utility Mobile user’s manual.
Place the CD in your computer’s CD drive, wait for the
“ECH2O Software Installer” to appear, and select “Install
ECH2O Utility Mobile” from the menu. If the installer
does not launch by itself, go to My Computer, select your
CD drive, and double-click on the “autorun.exe” file. 

The ECH2O Utility Mobile Installer first copies necessary
files to your computer and then launches Microsoft
ActiveSync to install ECH2O Utility Mobile on your
mobile device.

Updating ECH2O Utility Mobile
from the Web
Decagon publishes updates to ECH2O Utility Mobile on
the web. The update installer replaces the old version of
ECH2O Utility Mobile with the new release, while retain-
ing all your data and settings from the old version. You
can download the update installer at
www.decagon.com/echo/software.html. 
5
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You can check for new version of ECH2O Utility Mobile
software by running the “Check for ECH2O Utility
Mobile Updates” software on your desktop computer.
Click the Start menu, All programs, ECH2O Utility
Mobile and select Check for ECH2O Utility Mobile
Updates. This software uses the Decagon internet version
checker to see if there is a new version available. Your
computer must be connected to the internet for this ser-
vice to work.

NOTE: The updates to ECH2O Utility Mobile require resources
only available with the full installer that comes on the installation
CD.

You can check the version of ECH2O Utility Mobile you
are running by tapping the About ECH2O Utility menu
item in the Options menu.
6
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3. Configuring Your Logger  

To help you take full advantage of ECH2O Utility Mobile,
this chapter will demonstrate how to use the Direct
Connect mode with an ECH2O Logger. To connect to a
radio logger see Chapter 6, “Connecting via a Radio
Modem.”

The ECH2O Utility Mobile installer installs the software
in your Pocket PC device’s Programs directory. Tap the
Windows menu in the upper left corner of the screen and
7
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choose Programs. Tap the ECH2O Utility icon to launch
ECH2O Utility Mobile. 

When ECH2O Utility Mobile opens, it displays the
main screen. When not connected to a device, the words
“Not connected” are shown in the Device Identification
Area. Many of the controls are not enabled (grayed out
and not responsive to user input) until a device is con-
nected. The screen is divided into four main sections.
Each of these sections is explained in detail in the balance
of this manual. 

Tool Bar

Menu Bar

Device 
Identification 
Area

 

Data 
File 
List

SIP button
8
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NOTE: Tapping the SIP button activates the Soft Input Panel
(SIP) keyboard. The SIP is useful for inputting data and settings.
See your Pocket PC user manual for more information on using and
configuring the SIP.

Preparing to Connect to a logger
Now that the program is installed and running, the physi-
cal connection needs to be established. Connect the SCA
(Serial Cable Adapter) stereo connector end to the
COMM PORT on the logger. Next, connect the 9-pin
serial connector female end to the serial port on your
mobile device. See system requirements for more infor-
mation on mobile device serial port options.
9
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Connect via Direct

Choose “Connect via Direct” from the Options menu.
10
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When connection is established, all of the toolbar buttons
and many of the menu items are enabled, allowing you to
interact with the device. Some controls will only be
enabled with certain devices; for example, radio settings
will only be enabled when a radio equipped device (radio
logger or DataStation) is connected.

Configure 
Device 
button

Scan Ports 
button

Disconnect 
button

Download 
New Data 
button
11
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Device Status

The Device Identification Area displays information
about the currently connected device. For loggers it will
display the logger’s name, date and time. The battery sta-
tus icon is displayed on the right side of the Tool Bar. This
icon shows green for good battery status and red for low
battery status.

Tap and hold the Logger Battery Status icon to display a
tool tip showing the amount of battery life left in the bat-
teries. In the above figure, this logger’s batteries have 99%
of their life remaining.

Logger 
Name

Logger Date/Time

Logger Battery 
Status icon

Logger Battery Status 
icon Tool Tip
12
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Configure Device

ECH2O Utility Mobile makes it easier to view and change
device settings. If this is the first deployment or a re-
deployment of this device, you will want to change the set-
tings to meet your needs. To open the device settings
form, tap on the Configure Device button.

The Device Settings form has four tabs, Device, Measure-
ment, Radio, and Location. Non-radio loggers do not
show the Radio tab because they do not support a radio
module. DataStations do not show the Measurement tab
because they do not measure sensors.

Configure 
Device 
button
13
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Device tab

The Device tab displays the type of device that is con-
nected (Em50, Em5b or DataStation), the name and serial
number of the device, and the firmware version loaded in
the device. The only attribute you can change is the
device’s name. Use the SIP to enter a name for your device
that helps you organize and identify the data collected by
the device.

SIP button
14
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Measurement tab

The Measurement Tab is where you set the Measurement
Interval, choose sensors, and set the Power Noise Filter.
The Measurement Interval is the time in minutes the log-
ger waits between storing each reading. It is selectable
from 0 (no readings stored) to 1440 (one reading stored
every 24 hours). See your logger manual for more infor-
mation on the Measurement Interval.

The Em50 and Em5b logger require you to identify which
sensor is installed on each port of the logger. Pick the sen-
sor name from the combo box for each port. The combo
15
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box will only shows sensors compatible with your logger
model and logger firmware version.

NOTE: The Em5 logger auto-detects the sensors plugged into the
ports. The port sensor type combo boxes are disabled when connected
to an Em5 logger.

The logger’s Power Noise Filter is a setting designed to
minimize this electrical noise that comes from the AC
power system. The Alternating Current (AC) or “mains”
electrical power we use every day can add a subtle amount
of noise to the logger sensor measurements. You should
set the value of the Power Noise Filter to match the fre-
quency of the power cycle where you live. (North America
and most of Asia use 60 Hz, while in most of Europe it is
50 Hz.)
16
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Radio tab

You can configure radio settings in the radio tab. This
tab’s controls are only enabled when an Em50R or DataS-
tation is connected. For more information on setting the
Radio Mode, Radio Channel, and Sub Channel, see Chap-
ter 5, “Radio Telemetry.”
17
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Location tab

The information entered in the Location tab is designed
for use with DataTrac. This is where you can enter the
device location information. As with the other tabs, the
SIP is enabled to make it possible for you to enter the
information. You can enter as much or little information
that will be helpful. There is a space for the Farm name,
Field name, and geographical coordinates in Latitude
(North or South in Degrees and decimal Minutes) and
Longitude (East or West in Degrees and decimal Minutes).
DataTrac uses this information to help you organize your
loggers.
18
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Review the settings and when you are confident they are
correct, tap the “ok” button in the upper right corner and
the settings are saved to the device. 

Scan Ports

Now that all the device settings have been configured, it is
time to test the system to make sure the sensors are
responding correctly. Do this by using the Scan Ports but-
ton.

Scan 
Ports 
button
19
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The Scan Ports screen makes a real-time measurement on
each of the ports and displays the measured response in
the processed format for the given sensor. The processed
format (units) can be changed in the Options > Prefer-
ences > Units screen. This will be covered in more detail
later.

The Scan Ports screen is also designed to provide two
other data formats that can be displayed for help in dis-
covering any installation issues. The data can be displayed
as Unprocessed Data or as Millivolt data. Unprocessed
Data is in ADC counts (Analog to Digital Converter
counts or raw counts). When a sensor value is outside the
20
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range used to convert to processed data, the processed
displayed value will be three asterisks “ * * * ”. See Chap-
ter 9, “Troubleshooting” for more information about this.
Switching to the Unprocessed Data view can make it eas-
ier to determine the condition of the sensor or connec-
tion. The Millivolts display can be used in a similar
manner. 

After confirming that the device is set up and operating
properly, tap the “ok” button and you are returned to the
main screen.

When the logger has been configured, it will not begin to
log data until you disconnect from the device. Tap the
Disconnect button and the device is set to collect the data
from the sensors at the programmed interval.

Disconnect 
button
21
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4. Downloading Data

After your logger has collected data, you can use ECH2O
Utility Mobile with your PDA to act as a data shuttle from
the logger in the field to your desktop computer. ECH2O
Utility Mobile creates DataTrac XML Data (.dxd) files
with the data it downloads from your ECH2O logger or
DataStation. See the section “Transferring data files to a
desktop PC” later in this chapter for instructions on how
to move your data to your computer. 

Once your measurement data is on your PC, you can
import the data into ECH2O DataTrac or use ECH2O
Utility (for desktop computers) to convert the DXD file
into an Excel file. Please see the DataTrac manual or your
logger manual for more information on your data
processing options.
22
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To download data, make the physical connection as
described earlier. Start the ECH2O Utility Mobile pro-
gram and tap the Connect button. 

There are two downloading methods, “Download New
Data” and “Download All Data.” “Download New Data”
downloads all the data that has been collected since the
last time data was downloaded. The “Download New
Data” command can be accessed from both the “Down-
load New Data” button on the tool bar or from the
Actions menu item. 

Download 
New Data
button
23
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“Download All Data” downloads all the data that is stored
in the device. The “Download All Data” command is
accessed only through the Actions menu item. 

After the download is complete, a listing is displayed in
the Data File List area. The Data File List area displays
information about the device data that has been down-
loaded, such as the device’s name, the number of data
scans, and the start and end date of the saved data.
24
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Unless some changes need to be made to the device set-
tings, the device can be disconnected. If you should forget
to tap the Disconnect button and remove the physical
connection first, the program will detect the loss of con-
nection and reset itself to a not connected state.

 

Data 
File 
List 
area
25
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Displaying Data 

You can view the raw downloaded data after the download
is finished. Tap twice on the file listing displayed in the
Data File List area and the ECH2O Utility Mobile displays
data from the file. 

The data shown in the Data File view is the raw data
recorded by the logger. The Data File view is useful for
verifying a good download while in the field. You should
use ECH2O DataTrac or ECH2O Utility to convert the
raw data. 
26
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NOTE: The Data File view can only display 160k characters. If
the file you are viewing contains more characters, you will only see the
first 160k characters.

Erasing Data 

Also located on the Actions menu is the “Erase Stored
Data...” command. This command is intended to be used
after all the data has been downloaded and before starting
the collection of the next sequence of data. For example,
you would want to erase stored data before reassigning the
logger to a new location or before starting a new season.

Transferring Data Files to a Desk-
top PC 

These instructions will help you get the data collected by
your loggers onto you computer for further analysis.
Before you can transfer data, you need to connect your
mobile device to the computer using ActiveSync. For
more information on using ActiveSync, see the user man-
ual that came with your Pocket PC PDA.

Transferring Data to DataTrac

1. Connect your PDA to your computer
2. Launch ActiveSync. You can launch ActiveSync by 

clicking the Start button on your Windows PC. 
Choose “All Programs”, “ECH2O Utility Mobile” and 
then click “Launch ActiveSync”.
27
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3. Click the Explore button on the ActiveSync toolbar. 
This opens an explorer window for the files stored on 
your PDA.

4. Open the “ECH2O Data” folder. Select all the DXD 
files.

5. Choose “Copy” from the Edit menu if you want to 
leave the data files on your PDA. Choose “Cut” from 
the Edit menu if you want to remove the files from 
your PDA. 

6. Open the DataTrac “Import” folder. This folder is 
created by DataTrac in the same directory where the 
DataTrac program files is located. The typical location 
is C:\Program Files\Decagon\ECH20 
DataTrac\Import.

7. Choose “Paste” from the Edit menu. This copies (or 
moves) all the data files from your PDA to your desk-
top computer.

8. Launch DataTrac. DataTrac imports any DXD data 
files in the Import directory

NOTE: The “errlog.txt” file in the ECH2O Data folder on your 
PDA is used by ECH2O Utility Mobile to log information and 
errors when the software runs on your PDA. You should not copy 
this file to the DataTrac import folder.

Transferring Data to ECH2O Utility

1. Create a folder on your computer to store the files 
transferred from your PDA. You might make a folder 
called “ECH2O Data” in your “My Documents” 
folder on your computer.

2. Connect your PDA to your computer.
28
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3. Launch ActiveSync. You can launch ActiveSync by 
clicking the “Start” button on your Windows PC. 
Choose “All Programs”, “ECH2O Utility Mobile” and 
then click “Launch ActiveSync”.

4. Click the “Explore” button on the ActiveSync toolbar. 
This opens an explorer window for the files stored on 
your PDA. 

5. Open the “ECH2O Data” folder. Select all the DXD 
files.

6. Choose “Copy” from the Edit menu if you want to 
leave the data files on your PDA. Choose “Cut” from 
the Edit menu if you want to remove the files from 
your PDA.

7. Open the folder you created in Step 1. Choose “Paste” 
from the Edit menu. This copies (or moves) all the 
data files from your PDA to your desktop computer.

8. Launch ECH2O Utility. Choose “Convert ECH2O 
DataFile...” from the File menu. Use the Open File 
dialog to locate and open the files you transferred to 
your computer. You can then export the raw data in 
the DXD file to an Excel or text file. For more infor-
mation about your data processing options, please see 
your logger manual.
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5. ECH2O  Radio Telemetry                          

This chapter gives you a brief overview of the radio telem-
etry available in the ECH2O system. This information
only applies to Em50R. The ECH2O system supports two
types of radio telemetry: “Two-way” modes and “Trans-
mit” modes. Consider one or both types of radio modes
when designing your ECH2O telemetry system.

ECH2O Telemetry networks require each remote radio
logger to have a unique name. Each logger leaves the
factory with the name set to the logger’s unique serial
number. You can easily change the name of the logger to
help you identify or organize your data. You should not
give two loggers the same name. Two loggers with the
same name will interfere with each other when communi-
cating over the radio.

Two-way Radio Telemetry
The Two-way Telemetry Mode lets you establish a two-
way connection with a remote radio logger. Once con-
nected to the remote logger, you can download data and
change most settings just like you were connected directly
to the logger with a serial cable. Communicating with a
remote radio logger requires you to have a Rm1 radio
modem connected to your mobile device. Connecting to
the remote radio logger happens through the Rm1.
30



ECH2O Utility Mobile User’s Manual
5. ECH2O Radio Telemetry
When a logger is in a Two-way Radio Mode, it turns on its
radio every 45 seconds. While the radio is on, the logger
listens for connection attempts from an Rm1. If the
logger doesn't hear any connection attempt, it turns off
the radio. If the logger hears a connection attempt, it
leaves the radio on for several seconds listening for login
commands from ECH2O Utility Mobile. It takes up to 60
seconds to connect to the remote logger.

When you are finished interacting with the remote radio
logger, you press the disconnect button. ECH2O Utility
Mobile sends a “logout” command to the remote logger
to indicate the end of the communication session. When
the remote logger hears the “logout” command, it waits
for 10 minutes before listening for additional connection
attempts via the radio (you can always direct connect to
your logger). This allows you to connect to other loggers
with the same radio settings. Otherwise the first logger
may reconnect, preventing you from connecting with
other loggers.

The Two-way modes generally require the most battery
power. The Em50 is designed to work for several months
in the Two-way modes.

Two-way Radio Modes
Use the Radio Tab in the logger settings form to choose
one of the following radio modes that support two-way
communication.

Two-way 24-hour: The radio logger listens for connec-
tion attempts every 45 seconds, 24 hours a day.
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Two-way 6:00-18:00: The radio logger listens for
connection attempts every 45 seconds between 6 AM and
6 PM. The logger doesn’t use the radio between 6 PM and
6 AM to conserve battery power, by not listening for con-
nection attempts during the night.

Transmit + Two-way and CD Transmit + Two-way:
These modes combine the Two-way Radio modes and the
Transmit Radio modes. You could use these modes while
configuring and testing your radio network. You should
not leave your radio logger in these modes because they
use the most battery power of all the radio modes.

NOTE: Using Transmit + Two-way and CD Transmit + Two-
way radio modes with the wake interval set to 1 or 2 will cause the
batteries of your logger to drain very rapidly.

Two-way Best Practices
Two-way modes are most useful when you have a small
numer (one, two, or three) of remote radio loggers you
wish to contact. If you have three or more loggers
installed within radio range of each other, consider using
one of the Transmit modes. The Two-way modes also
allow you to mount an Rm1 in your vehicle and interact
with the remote logger while in radio range.

See Chapter 6, “Connecting via a Radio Modem” for step
by step instructions for establishing a two-way connection
with a remote radio logger.
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Transmit Radio Telemetry
The Transmit Radio modes help you create a simple
network of remote radio loggers all transmitting data to a
DataStation radio base station. The DataStation stores
data from all the remote loggers in one convenient place.
Typically a DataStation is connected to your computer
where you can easily download the data for use in ECH2O
DataTrac. Unlike the Two-way Radio modes, you can't
remotely change logger settings when using this mode.

When a logger is in Transmit mode, it only turns on the
radio when it has new data to broadcast. For example,
when you set the measurement interval in your logger to
60 minutes, the logger stores your data every hour and
then broadcasts the data to a listening DataStation. The
actual transmit time is randomly delayed for several
minutes to prevent two or more radio loggers from
interfering with each other. 

The Transmit radio modes use less battery power because
the radio is off most of the time. The Em50 is designed to
work for many months in Transmit mode.

NOTE: A DataStation is a receiver. It doesn’t cause the remote
logger to send data. If your DataStation is powered off for some time,
it won’t receive data sent by the remote loggers. The missing data is
still stored in the logger; however, the DataStation has no way to
retrieve the missing data. You can directly connect to the logger to
download the missing data.
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Transmit Radio Modes
Use the Radio Tab in the logger settings form to choose
one of the following radio modes that support Transmit
communication.

Confirmed Delivery Transmit: This is the most robust
Transmit radio mode. The radio logger adds a checksum
to the data packet before broadcasting the data to a
DataStation. The logger then waits for the DataStation to
confirm it correctly received the data packet. If the logger
doesn’t hear the confirmation, it retries sending the packet
again. The logger stops trying to transmit to a DataStation
after 25 attempts. The logger will attempt more transmis-
sions after the next measurement interval.

Transmit Only: The radio logger broadcast 1 datapacket
to the DataStation. This is the original Transmit radio
mode. It doesn’t offer the advantages of the Confirmed
Delivery Transmit mode. You should use the Confirmed
Delivery mode when possible. Em5R (discontinued) log-
gers only support this Transmit radio mode.

Transmit + Two-way and CD Transmit + Two-way:
These modes combine the Two-way Radio mode and the
Transmit Radio mode. You could use these modes while
configuring and testing your radio network. You should
not leave your radio logger in these modes because they
use the most battery power of all the radio modes. Using
Transmit + Two-way and CD Transmit + Two-way radio
modes with the wake interval set to 1 or 2 will cause the
batteries of your logger to drain very rapidly.
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Transmit Best Practices
Transmit modes are most useful when you have three or
more loggers installed within radio range of each other.
There is no hard limit to the number of radio loggers
broadcasting to a DataStation. Use this mode for as few as
one logger and as many as 50 or more loggers. You should
use the Telemetry Test feature of ECH2O Utility Mobile
to test the connection from your logger to the DataSta-
tion.

NOTE: Em50R loggers must have firmware version 1.12 or later
to enable the Confirmed Delivery Transmit mode and Telemetry Test
feature. Your DataStation must have firmware version 1.09 or later
to receive Confirmed Delivery Transmit mode data packets. Contact
Decagon for an application note that covers the steps needed to
upgrade your hardware.

See Chapter 7, “DataStation Networks” for step by step
instructions for configuring your DataStation and remote
radio loggers.

Radio Settings
For two radio devices to communicate they must share the
same radio settings. An Rm1 radio modem can only con-
nect to a remote radio logger with the same radio settings.
A DataStation will only receive data from loggers with the
same radio settings as the DataStation. Set the Radio
Channel to the same value for all the devices on the same
network. Set the Radio Sub Channel to the same value for
all the devices on the same network.
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Radio logger networks with different values set for the
Radio Channel use different frequency-hopping
sequences, and therefore experience minimal interference
between groups. Radio logger networks with the same
Radio Channel value but different Radio Sub Channel
values can interfere with each other, but can’t
communicate with each other. This interference can also
cause additional battery drain in the radio logger.

The default value for Radio Channel and Sub Channel
value are zero. Use the Radio Tab in the logger or
DataStation settings form to choose other values.

Radio Performance
The maximum range of the radio modules in the radio
logger and DataStation are effected by the environment,
installation method, and antenna choice. Maximizing the
range of your radio network requires you to consider all of
these factors.

Buildings, hills, vegetation, vehicles and other
environmental obstructions will shorten the radio’s range
– sometimes drastically. You should ensure a clear, open
path between radio devices. Also, radio frequency (RF)
interference in the environment around the radio can
reduce the usable range (even if not using the same radio
frequencies). You should consider nearby growing
vegetation when designing and testing your radio network.
Some radio networks work fine when the vegetation is
sparse; however, they may fail when vegetation is full.
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You can increase the effective transmit range by
maximizing the height above ground of the radio antenna.
This helps ensure a clear path for the radio signals and
reduce the amount of signal absorbed by the earth. Use an
antenna extension cable to help you position your antenna
when it isn’t practical to install your logger higher off the
ground. If you mount your radio logger to a metal pole,
you should mount your antenna to the top of the metal
pole so it is free to radiate the signal above the pole.

Replacing the stock antenna on your radio device with a
high-gain antenna can greatly increase the radio range.
Consider using a directional Yagi antenna or a high-gain
omni-directional antenna when you want to extend the
range of your radio network. A high-gain antenna can also
help overcome the effects of unavoidable environmental
obstructions.

The ECH2O telemetry system also supports a simple relay
for use with Transmit Mode networks. Combining a relay
and high-gain antennas allows radio devices to    commu-
nicate over very long distances. Contact Decagon for
more information on using a relay in your radio       net-
work.
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6. Connecting via Radio
Modem

Connecting to a radio logger via an Rm1 requires a few
steps different from Direct Connecting to a logger. You
should keep notes concerning the logger name and radio
settings to make the rest of the system configuration easier
to accomplish. First, configure your radio logger to listen
for two-way connection attempts.
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Direct Connect to a radio logger to set the device’s radio
settings. After establishing a connection, tap the Configure
Device button. Tap the Radio tab. The Radio tab displays
the Channel, Sub Channel, Radio Mode, and Radio
Firmware Version of the logger’s radio module. Channel
can be set from 0 to 6 inclusive (default is 0). The Sub
Channel can be set from 0 to 65534 inclusive (default is 0). 
To use the radio logger with an Rm1, the Radio Mode has
to be set to one of the Two-way modes.

If the Two-way 6:00-18:00 mode is chosen, then
connection via the Rm1 can only take place between the
hours of 6:00 AM through 6:00 PM. This mode was
designed to improve battery life by not keeping the radio
on constantly. The other Two-way modes can be
connected to 24 hours a day. 

After setting the Radio Mode, tap the “ok” button.
Disconnect from the radio logger.

Connect your PDA to the Rm1 by using a standard 9-pin
serial cable. On some devices, ActiveSync starts trying to
make a connection to your desktop computer when it
senses the connection to the Rm1. ActiveSync will prevent
ECH2O Utility Mobile from connecting to your remote
logger. See Chapter 9, “Troubleshooting” for a way to pre-
vent the ActiveSync interruption.
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Tap Connect via Rm1 from the Options menu.

Tap the Connect button. 
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The Logger Query Configuration form will appear. To
connect to a specific logger, type the logger’s Name (use
the SIP to type the name), Channel, and Sub Channel.
After typing the name, tap the Query button. Leave the
Name field blank to connect to any logger listening on a
radio Channel/Sub Channel.

NOTE: To connect to a radio logger, the radio Channel setting
must be the same for both the logger and the Rm1. The radio Sub
Channel setting must also be the same for both the logger and the
Rm1.
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The Connection Progress screen will appear as ECH2O
Utility Mobile tries to establish a radio connection with
the remote logger through the Rm1. The connection
process can take up to 60 seconds while ECH2O Utility
Mobile sends a logger “wake up” signal and retries the
connection attempt.
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When ECH2O Utility Mobile connects to a remote radio
logger, it shows the signal strength of the connection with
the radio signal strength icon on the tool bar. Tap and
hold the radio signal strength icon to see a tool tip
showing the signal strength percent.

See Chapter 9, “Troubleshooting” if ECH2O Utility
Mobile fails to connect to your remote logger.

Once ECH2O Utility Mobile establishes a two-way radio
connection with a remote logger, you can interact with the
logger just like a direct connection.

NOTE: You cannot change the radio Channel or radio Sub Chan-
nel settings while connected via the Rm1.

Radio Signal 
Strength iconRadio Signal 

Strength Tool 
Tip
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7. DataStation Networks

Configure a DataStation 

Direct Connect to a DataStation to set the radio settings.
After establishing a connection, tap the Configure Device
button. Tap the Radio tab. The Radio tab displays the
Channel, Sub Channel, and Radio Firmware Version of
the logger’s radio module. The Radio Mode setting doesn’t
apply to the DataStation. Channel can be set from 0 to 6
inclusive (default is 0). The Sub Channel can be set from 0
to 65534 inclusive (default is 0). 
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Note the Channel and Sub Channel settings chosen. Tap
the “ok” button to save the settings to the DataStation.
Disconnect from the DataStation. 

Configure a Radio Logger
To use one or more radio loggers with a DataStation the
Radio Mode has to be set to one of the Transmit modes.

Direct connect to a radio logger. Set the radio Channel
and Sub Channel settings to exactly the values chosen for
the DataStation previously. Set the Radio Mode to
Confirmed Delivery Transmit. This mode provides a
method for confirming the delivery of the data which
greatly increases the ability of the system to successfully
transfer the data. The Transmit + Two-way modes are
there for use as troubleshooting aids. 

After setting the Radio Mode, tap the “ok” button. 
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Telemetry Test 

The Telemetry Test allows you to verify the radio
connection between the radio logger and the DataStation.
Tap the Actions menu. Tap the Telemetry Test menu and
the Telemetry Test window opens.
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Tap the Test button and the test will begin. When the test
has finished you will be presented with the results of the
test.

You may have to relocate the radio logger while doing the
Telemetry Test in order to find the best connection
quality. Once you have found the radio logger location
that provides the best connection quality, install the radio
logger at that location. Disconnect from the radio logger.

NOTE: Telemetry Test only works with Em50 loggers running
firmware 1.12 or newer.
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Download Collected Data
After the DataStation has collected data, you can retrieve
the data for permanent storage and analysis. Start the
ECH2O Utility Mobile program. Verify that the “Connect
via Direct” option is chosen from the Options menu.

Tap the Connect button.

Tap the “Download New Data” button. The Download-
ing DataStation Data screen will appear and provides a
progress bar displaying the download progress.

When the download is completed, the Downloading
DataStation Data screen will close and a file listing will be

 

Data 
File 
List 
area
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displayed in the Data File List area. The Data File name
listed under the Device column is the DataStation name. 

The name of the logger that the data came from is in the
first column of the data contained in the file. If data was
collected from more than one logger, then each logger’s
name would be found in the file with its associated data.

The PDA does not need to be connected to the DataSta-
tion for you to view the data.
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8. ECH2O Utility Mobile
Features

Menu Bar

The Menu Bar allows you to perform operations and
access program features. ECH2O Utility Mobile’s menu
bar contains two menu items, some of them containing
sub-menu items.

Options

The Options Menu allows you to choose the type of
connection to make, set the Preferences of ECH2O Utility
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Mobile, and display the Version information. These items
are always enabled whether a device is connected or not.

Connect via Direct
Connects to a logger through the COM port selected in
the “Use Comm Port” combo box. The “Use Comm
Port” combo box is located under Options > Prefer-
ences > Communication. This option is enabled when a
dot is displayed to the left side of the text.

Connect via Rm1 
Used to connect to any radio logger on a specified Radio
Channel/Sub Channel. Both the logger and the Rm1 must
be set to the same Channel/Sub Channel values. This
option is enabled when a dot is displayed to the left side of
the text.

Preferences
The Preferences menu allows you to select the units you
wish ECH2O Utility Mobile to use when displaying data,
adjust communications settings, and adjust application set-
tings. This menu features three sections, accessed by click-
ing the tabs at the bottom of the screen.
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Units 

This is where the displayed units for the collected data are
set. For example, Temperature can be displayed in one of
two ways, either using the English units of Fahrenheit or
the Metric units of Celsius. Tap on the combo box that
corresponds to the desired unit. To save the selected
changes, tap the “ok” button. More than one tab’s worth
of changes can be made at a time in the preferences area.
Select each tab one at a time, change the desired settings
for that tab and then tap “ok” to save all the changes at
once.
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Communication

Direct Connect Retries. If you are experiencing unreli-
able communication with a logger, set the number of
times the PDA will attempt to send commands to a logger
from 3 to 10 times (usually, no more than 3 tries should be
necessary).

Radio Connect Retries. If you are experiencing unreli-
able communication with a radio logger while using a
Rm1, set the number of times the computer or PDA will
attempt to send commands to a radio logger. This value is
selectable from 5 to 12 times.
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Maximum Baud Rate. Set a baud rate lower than the
default 115,200 baud if you consistently experience a noisy
serial connection, as exhibited by frequent logger discon-
nects.

Use Comm Port. Comm1: is the default communication
port for most mobile devices. If your mobile device has
more than one communication port or you are using a
Compact Flash serial card, you can choose the appropriate
communication port number here.

Application 
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By default, ECH2O Utility Mobile automatically
synchronizes the logger’s date and time to the time set on
the Pocket PC device. Tap the check box to disable this
feature. You can update the date and time manually
anytime you are connected by selecting Actions > Set
Date/Time. 

The amount of detail stored into the error log file is
adjusted here. By tapping the “Add more detailed error
messages to error log files” check box increases the
amount of detail stored in the error log files.

For the Pocket PC devices that can change the display to
landscape mode (not all do) there is the “Automatically
change display mode to Portrait when launching ECH2O
Utility” check box. As its title implies, this will change the
display mode from landscape to portrait when ECH2O
Utility starts.

About ECH2O Utility
The About ECH2O Utility screen displays the version
number, the build number, and the Protocol version
number used in this ECH2O Utility Mobile release. It also
contains the mailing address, phone numbers, e-mail
address, and website for Decagon Devices.
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Actions

Many of the Action menu items are only enabled when a
device is connected. 

Download New Data
This control will download any new data stored in the
device. New data is defined as data that has not been
downloaded since the last download.

Download All Data
This control will download all data stored in the device
regardless of when the last download was done.
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Erase Stored Data...
This control will erase all the data stored in the connected
device. 

Warning! Erasing the data stored in your ECH2O
device completely removes the data. Erased data can-
not be recovered!

Set Date/Time
This control allows you to manually syncronize the date/
time of the connected logger to the current date/time of
the Pocket PC.

Telemetry Test
This control is only enabled when connected to a radio
logger. This tests the telemetry signal between the radio
logger and a DataStation. It tests not only for signal
strength, but also for payload (data packet) confirmation.
See Chapter 7, “DataStation Networks” for further infor-
mation.
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Device Tools 

Test Device Firmware
This will test the logger’s firmware. A dialog box appears
indicating whether the firmware has tested Good or Bad.
For more information on firmware and obtaining updates,
please see the Troubleshooting section.

Initialize Radio Module
This feature will reset the radio and all associated settings
(Em50R, Em5R, and DataStation only). 
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Initialize Device ...
Occasionally, it may be necessary to reset a logger if you
are continually getting unreliable communications from it.
Click on Initialize Device. This will completely reset the
system, and erase data stored on it. 

WARNING! Initializing your ECH2O device com-
pletely removes the data stored in the device. Erased
data cannot be recovered! 

Configure Radio Modem

Configure Radio Modem is only enabled when no device
is connected. This allows you to set the Radio Channel/
Sub Channel of an Rm1. This is useful for configuring a
simple relay.
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9. Troubleshooting

ECH2O Utility Mobile is designed and tested to commu-
nicate correctly and robustly with your ECH2O devices.
Sometimes problems can still occur when it tries to com-
municate with your ECH2O devices. This chapter outlines
some of the common issues and suggested solutions. If
you find a problem not covered here, please contact Deca-
gon for help.

Troubleshooting Direct Connections 

PROBLEM: ECH2O Utility Mobile tells me it can’t
connect to my device.

SOLUTION: Try one or more of the following to make
sure there is a serial connection to the ECH2O device:

• Check to make sure “Connect via Direct” is selected
in the Options menu.

• Check your serial cables are securely plugged into
your logger or DataStation and your PDA.

• Make sure you are using the correct communication
port on you PDA. The default Comm Port on most
PDAs is “COMM1:”. If you are using a CF serial
card, “COMM1:” is probably not the right setting.
You can change the Comm Port setting on the Com-
munication tab in the ECH2O Utility Mobile Prefer-
ences. 
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• Make sure your logger has good batteries or your
DataStation is plugged in. Try pressing the reset but-
ton on your logger or DataStation.

NOTE: Serial cables can fail. If you suspect your serial cable may
be the problem, try connecting to a second logger. If you can connect,
the problem is probably the first logger. If you can’t connect to the sec-
ond logger either, the problem may be your cable. Try using a spare
Decagon Serial Cable Adapter if you are having trouble connecting
to a logger. The serial adapter for your PDA could be the problem.

PROBLEM: ECH2O Utility Mobile tells me my
Comm port isn’t available.

SOLUTION: Make sure you are using the correct com-
munication port on your PDA. The default Comm Port
on most PDAs is “COMM1:”. If you are using a CF serial
card, “COMM1:” is probably not the right setting (use the
software that comes with your CF Card to determine the
correct Comm number). You can change the Comm Port
setting on the Communication tab in the ECH2O Utility
Mobile Preferences.

PROBLEM: ECH2O Utility Mobile tells me my
Comm port is already in use. 

SOLUTION: Another software program on your PDA
must be using the serial port. Quit any software that uses
the serial port before using ECH2O Utility Mobile (GPS
software is a common example). You can use the Memory
Settings panel on your PDA to stop running programs. If
no other software is running on your PDA and you still
get this error, try pushing the reset button on your PDA.
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PROBLEM: ECH2O Utility Mobile keeps reporting
it lost the connection to my device. 

SOLUTION: This rarely happens for a direct connec-
tion. Please check or replace your serial cables. You can
also increase the number of times ECH2O Utility Mobile
tries sending commands to the logger or DataStation.
Increase the Direct Connect Retries on the Communica-
tion tab of the Preferences form. 

Troubleshooting Radio Connections

PROBLEM: ECH2O Utility Mobile tells me my
Radio Modem isn’t responding.

SOLUTION: Make sure your serial cable is securely
attached to your PDA and your Rm1. Your Rm1 should
have power and be turned on. If you are trying to directly
connect to an ECH2O device, make sure “Connect via
Direct” is selected in the Options menu.

PROBLEM: Anytime I try to connect via a Radio
Modem, a dialog box called “Connect To” opens. 

SOLUTION: This is ActiveSync trying to use the radio
modem to establish a connection to your desktop com-
puter. This process keeps ECH2O Utility Mobile from
connecting to your remote logger. You can try pressing
the “Cancel” button in the “Connect To” dialog box;
however, this doesn’t always solve the problem. The only
reliable way to prevent ActiveSync from sensing the
modem connection is to remove pin one from the 9-pin
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male end of the serial cable you use to connect to the
Rm1. The illustration below shows the location of pin
one. Use small needle-nose pliers to pry and twist the pin
to remove it from the cable. 

PROBLEM: ECH2O Utility Mobile tells me it can’t
connect to my radio logger when I’m using an Rm1. 

SOLUTION: Try one or more of the following to make
sure there is a good radio connection to your remote log-
ger: 

• Make sure you are within radio range of the remote
logger. Increase the radio signal strength to your log-
ger by moving closer to your logger or using a high-
gain antenna to see if you can establish a radio con-
nection.

• Make sure the antenna on the logger and the Rm1
are securely fastened to the radio module.

• Check the Radio Channel and the Radio Sub Chan-
nel settings you are using on your remote loggers
and Rm1. See Chapter 6, “Connecting via a Radio
Modem” for how to configure your radio settings.

• Make sure you wait 10 minutes between connection
attempts for the same logger. If you just discon-
nected from a logger, you must wait for 10 minutes

1 2 3 4 5

6 7 8 9
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before that logger will accept radio connections (
you can always direct connect to your logger).

• Make sure your logger has good batteries. Try press-
ing the reset button on your logger.

PROBLEM: ECH2O Utility Mobile keeps reporting
it lost the connection to my device. 

SOLUTION: This can happen when the radio connec-
tion is lost. Try increasing the radio signal strength by
moving closer to the remote logger or using a high-gain
antenna. You can also increase the number of times
ECH2O Utility Mobile tries sending commands to the
logger. Increase the Radio Connect Retries on the Com-
munication tab to the Preferences form.

Troubleshooting Data Issues

PROBLEM: ECH2O Utility Mobile tells me there is
no new data for downloading. 

SOLUTION: Make sure the logger is configured to mea-
sure data. Check the measurement interval is set to a num-
ber greater than zero. Try pressing the reset button if the
logger does have a non-zero measurement interval.

PROBLEM: My sensor data shows “ * * * ” in the
Scan window.

SOLUTION: The three asterisks mean the raw data mea-
sured by the logger is out of expected range for the sensor.
This could be caused by a broken sensor. Make sure the
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sensor is fully inserted into the logger’s sensor port. Make
sure the sensor type shown in the Scan window matches
the sensor actually connected to your logger.

Troubleshooting Software

PROBLEM: When I try to launch ECH2O Utility
Mobile, I get an error message that says: “Cannot
find ‘ECH2O Utility’ (or one of its components).
Make sure the path and filename are correct and that
all the required libraries are available.” 

SOLUTION: Your PDA may not be compatible with
ECH2O Utility Mobile. Please review the system require-
ments in Chapter 1, “Introduction”. Contact Decagon if
your device uses one of the operating system versions
listed.

PROBLEM: When I try to launch ECH2O Utility
Mobile, I get an error message titled “ECH2O Utility
Missing Files!”

SOLUTION: The version of ECH2O Utility Mobile you
installed is from an update installer. The update installer
doesn’t include all the resources needed to run ECH2O
Utility Mobile. Please reinstall ECH2O Utility Mobile
from your installation CD. Then install the update version.
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